Software

  • Drupal 9.0+
  • PHP 7.3+
  • CMS Content Sync Drupal module installed on all relevant environments: https://www.drupal.org/project/cms_content_sync
    • Please note that the module has to be downloaded with Composer so that all dependencies are resolved correctly. If the module isn't installed with Composer, you may run into difficulties due to missing modules, missing libraries or version mismatches.
    • All connected sites must use the same module version. So if you want to update the module, you need to update it on all sites.
  • If you are using paragraphs, Paragraph Version >= 8.x-1.3 is required.



Configuration

  • Entity types and bundles must have the exact same configuration on all sites.
    • You can use the "Show version mismatches" functionality after installing and configuring the module on your sites to see all relevant configuration differences between your sites.



Traffic

  • In order to work with a Sync Core provided by Edge Box, the environment must be accessible from the internet.
    • If you want to have a dedicated Sync Core instead, please use our chat support.
  • Drupal must be allowed to connect to the Sync Core via HTTP/HTTPS.
  • The Sync Core must be allowed to connect to Drupal via HTTP/HTTPS.
  • If you host the Sync Core yourself, it must be allowed to connect to our licensing backend (app.cms-content-sync.io).
  • If you need a static IP address to receive requests from you can whitelist the following IP addresses, e.g. to not require Basic Auth:
    • Sync Core US
      • 3.222.171.239
      • 34.205.151.183
    • Sync Core EU
      • 63.34.184.33
      • 63.35.18.137



Supported versions

All our releases are supported for 6 months. The Sync Core and the Module are interoperable for 6 months, too. We still recommend to update the module more regularly, but if you are using a release for more than 6 months we may not be able to support you.

To support you with testing and releasing updates you can connect as many testing sites as you like free of charge.


Drupal Module
<= v1.57
Not supported
v2.0Not supported
v2.1Until November 2022
v2.2Recommended version
PHP Library
< v3.1Not supported
v3.1Recommended version
Sync Core (on-premise)
<= v1.55
Not supported
v2.0Until September 2022
v2.1Until October 2022
v2.2Until October 2022
v2.3Until November 2022
v2.4Recommended version